Okay
  Public Ticket #2823467
Pagination breaks the posts listing
Closed

Comments

  •  1
    Olivier started the conversation

    Hi, I'm using TP Dynamic Listing in an Elementor Template file used when displaying any archive page.

    This used to work fine but after a problem with the hosting we had to move the WP Install from its own directory back to root level. As you can imagine we needed to fix a lot of things in order for the website to work perfectly again.

    Everything seems to be fixed now except for one thing: We are still having problems displaying archive pages using TP Dynamic Listing:

    1 - The archive pages kept on breaking so thinking this was coming from the posts themselves I re-created them, edited/changed categories, etc... only to find out that the page breaks when the TP Dynamic Listing's Page Loading Options is set to Pagination AND the number of posts in the category exceed the widget's Maximum Post Display number (as seen here: https://powertrans.com.au/category/tempcat/ )
    You will also notice that not only this blocks the page from displaying the posts but also impact other parts of the page ( Title, Menus with sub-menus not working anymore, layout/padding,...)

    2 - The widget is set (always has been) to display the posts in 3 columns but something is now pushing the third column to move to the next row (see the "news" category page here: https://powertrans.com.au/category/news/ ). This worked perfectly well before and we haven't changed anything regarding layout/css so I find this very strange. FYI you can briefly see the layout showing 3 columns when the page is loading but this quickly change to 2 columns.


    Can you please help me solve this issue ASAP. The website is live and our client is getting a new magazine out this week so thaye are pressing for the problem to be solved before.

    Thanks for your help.

    Cheers
    Olivier

  •  227
    Deekshit replied

    Hi Olivier 

    Thank you for contacting POSIMYTH support.

    Can you please share the site wp-admin login details and grant us permission to disable the plugins on your site and check?

    Note: Please make the  ticket private so that the logins won't be seen by other users.

    Thanks,

    Warm Regards,
    Deekshit Nair

    I'm located in India. My timezone is IST.

  •   Olivier replied privately
  •  227
    Deekshit replied

    Hi Olivier 

    Thanks for holding on, please check now and let us know if we can be of further assistance.

    Thanks,

    Warm Regards,
    Deekshit Nair

    I'm located in India. My timezone is IST.

  •  1
    Olivier replied

    Thanks Deekshit,

    May I ask you where the problem was coming from and what you did to fix it in case this happens again?
    Will this still work after the next update?

    Thanks again.

    Cheers
    Olivier

  •  227
    Deekshit replied

    Hi Oliver,

    We have update code in below file

    "wp-content\plugins\theplus_elementor_addon\includes\plus_addon.php"

    We'll add this in our next release.

    Thanks,

    Warm Regards,
    Deekshit Nair

    I'm located in India. My timezone is IST.

  •  1
    Olivier replied

    Thanks Deekshit,

    Great to hear the fix will be included in the next release.

    Cheers
    Olivier

  •   Deekshit replied privately
  •  1
    Olivier replied

    Hi Deekshit,

    I'll definitely share a review for you.

    There still seems to be a problem on the website and as this appears roughly after the changes you made I was wondering if these are related ?
    Elementor has been extremely slow to load (giving me the "can't edit ?" message box) and when I edit some part of a page (say image 2) after editing another part (say image 1) it applies the changes on the first selected part  (image 1) instead of the last one (image 2). This is especially the fact when editing a "complex" template like this one (Theme Single Article) using a few ACF Fileds.

    Any idea what could be causing this and how to fix it?

    Thanks
    Cheers
    Olivier

  •  227
    Deekshit replied

    Hi Oliver,

    Thanks for writing back, regarding the Elementor, not loading please increase the WP Memory limit to 1024M and change the permalinks from the admin panel Settings >> Permalinks section.

    Regarding the ACF issue, we have already replied to the other ticket please check and let us know if we can be of further assistance.

    Thanks,

    Warm Regards,
    Deekshit Nair

    I'm located in India. My timezone is IST.

  •  1
    Olivier replied

    Thanks Deekshit,

    I've replied to the ACF issue in the other ticket. Thanks for your help.

    Regarding increasing the memory: I had increased the memory limit in the wp-config.php file but the TP Settings Panel is still showing the previous memory limit. Does this mean I need to contact the hosting company to increase this for me?

    Permalinks: It is actually set to https://powertrans.com.au//%postname%/. Do you want me to change it to something else or simply re-save it ? What would you suggest I change the permalinks to? How does this impact the running of the website?

    Thanks again for your help.
    Cheers
    Olivier

  •  227
    Deekshit replied

    Hi Olivier,

    Yes, once you increase the memory please change the permalinks to any different permalink and save. Once done you can change it back to the original and check again.

    Thanks,

    Warm Regards,
    Deekshit Nair

    I'm located in India. My timezone is IST.

  •  1
    Olivier replied

    Thanks Deekshit, but I've increased the memory limit in the wp-config.php file, changed/saved the permalinks a few times , cleared caches, etc... but the TP Settings Panel is still showing the old limit (see attached).

    Is there a better way to increase the limit?

    Thanks
    Olivier

    Attached files:  config-memory-limit.png
      TP-memory-limit.png

  •  227
    Deekshit replied

    Hi Oliver,

    Please see here https://prnt.sc/1d1swrq as you can see that the memory is still showing 256M so it looks like I recommend you increase the same on the cPanel of your site.

    Thanks,

    Warm Regards,
    Deekshit Nair

    I'm located in India. My timezone is IST.

  •  1
    Olivier replied

    Thanks Deekshit,

    I've managed to increase the memory limit to 512M using PHP INI Editor in Cpanel. It definitely makes WP faster.
    Do you think it is safe to increase it even more?

    Thanks again for your help

    Cheers
    Olivier

  •  227
    Deekshit replied

    Hi Oliver,

    Yes, it is safe and the reason is that if you are using more plugins and have more data on your site then you need to increase the Memory on your site they could be using more resources which leads to slow performance on your site.

    So I recommend you can increase it to 1024 or 2048M 

    Thanks,

    Warm Regards,
    Deekshit Nair

    I'm located in India. My timezone is IST.

  •  1
    Olivier replied

    No worries Deekshit,

    Thanks again for your help.

    Cheers
    Olivier

  •  1
    Olivier replied

    Hi Deekshit,

    Regarding the memory issue: I would like to disable the TP Widgets I'm not using to decrease the load on the server but I want to make sure I don't disable a widget I might be using somewhere in the website.

    Is there a way to check which TP widgets are actually in use (and maybe where) ?

    Thanks
    Cheers
    Olivier

  •  227
    Deekshit replied

    Hi Oliver,

    Yes, you can disable some widgets but unfortunately, there's no way that you can know on the admin panel as you need to edit the Elementor page and check using Navigator as if you are using the widget or not.

    Thanks,

    Warm Regards,
    Deekshit Nair

    I'm located in India. My timezone is IST.