Okay
  Public Ticket #2127375
WPML
Open

Comments

  • Werner started the conversation

    I just started building a site for my first client.

    It will be multilingual (with WPML) with woocommerce.

    After several tests it came out that WPML seems not to be compatible with your widgets. I used "TP Text blocks", and WPML does not see the content with the advanced translation editor.

    I then made several tests with other widgets from Elementor, Elementor Pro and some other editors and they worked fine.

    Please help me use your widgets with WPML

    I use a paid version with licence for 1 site

  •  67
    Disha replied

    Hello Werner,

    We are happy to help you. Would you mind sharing your wp-admin access with us so We can take a detailed look in to this issues? 

    We are making this ticket private so You can share wp-admin access here. 

    Warm Regards,
    Disha Patel
    POSIMYTH Themes Team

    I'm located in India. My timezone is IST.

  • Werner replied

    Hello,

    I am simply asking you if your elementor widgets are compatible with WPML translation system. If yes, how can I make your widgets visible (all text strings) to WPML. If not, just tell me, so that I will not loose more time.

    A lot of third party elementor widgets are not compatible, so I start to get used. A lot of themes as well

    I use Ocean WP premium, which is compatible (not all of their widgets).

    I like very much your widgets, but as I depend totally from WPML to make and keep my pages multilingual, if it comes out that they are not WPML compatible, i have to stop using them.

    for info: https://wpml.org/

    Let me know


    Best regards

    Werner

  •  67
    Disha replied

    Hello Werner,

    I need to mention that, In a general way, It's WPML friendly but It's not fully WPML friendly. Especially based on their new page builder compatibility. We are working on that part as per WPML's Structure. 

    We got your point on exact  friendliness with WPML you are looking for. On that note, The Plus Addons isn't WPML friendly. 

    We are working on next version release with new widgets and features on a high priority and We will add this feature in next to next version's list.

    We will soon be WPML friendly based on their page builder based addon. 

    We are grateful to know, You love our addons. We are sorry for this WPML thing and You might not be able to use it. We can do one thing, If you have less widgets used on your website, We can  work on those widgets first and share that beta release just for you so you can use that in your project. We will release full WPML compatibility in our later version for public. (FYI: Even this beta release might take 10-20 Business days.)


    Warm Regards,
    Disha Patel
    POSIMYTH Themes Team

    I'm located in India. My timezone is IST.

  • Werner replied

    Hello

    How far are you with  the WPML compatibilitiy so far? 

    wich widgets are ok now?

    Can you send me a beta to test those widgets

    Berst regards

    Werner

  •  67
    Disha replied

    Hello Werner,

    We are sorry for delay but We are in touch with WPML Developers to make everything work 100% fine with WPML. Under their program, They are reviewing our code and give us final words and steps on this translation part. 

    We need to mention you that, it might take more days than expected. I will inform you as We will have new version ready with WPML's approval. 


    Warm Regards,
    Disha Patel
    POSIMYTH Themes Team

    I'm located in India. My timezone is IST.